[SOLVED][Drupal Errors] Compilation failed: this version of PCRE is not compiled with PCRE_UTF8 support

By | 11th Dec 2012 | 1 min read

Many Drupal users were encountering this error "Compilation failed: this version of PCRE is not compiled with PCRE_UTF8 support" in their Drupal site. If you are facing the same issue in your Drupal site then read on to find out the solution.

Follow the steps below to fix the error message.


First login as root
Then type
# pkg_info
This will display the installed packages
Now type
# pkg_delete pcre-6.4 (if you see pcre-6.4 as the installed version, modify the command as needed)
Next go to the directory where your ports collection is stored
For FreeBSD it is in:
/ports/devel/pcre-utf8
Therefore type
# cd /ports/devel/pcre-utf8
# make
# make install
# make clean

Now restart the Apache server and the error would have been gone.

Hope that helps.

The easiest way to solve a Drupal issue is to hand it to the Drupal experts. We can provide a wide range of Drupal services to help you maintain and manage your Drupal websites. Get in touch with us to know more.