Exim4

Solution to 'malformed macro definition' and 'DEBCONFsomethingDEBCONF found in exim configuration'

Upgrading a working server application is always tricky. This is especially true if the upgrade had changes in configuration files and you had customizations done in your local configuration file. The recent exim4 upgrade to version 4.67-3 had structural changes in the configuration files. The suggested upgrade method is to accept all the modifications provided by the upgrade and redo the customizations. But what if you did not read the instructions properly and ended having an exim4 installation that throws out errors every time you try to start exim4.